The Font Creator Program 

REVISION HISTORY
4.1 [December 1, 2003]
· Improved support for Supplementary Multilingual Planes (SMP)

· Added snap points to diagonal guidelines

· Extended search glyph functionality

· Added measurement feature

· New freehand selection toolbar button

· Improved redundant point validation

· Changed the Validation report into a wizard

· Added auto fix functionality that solves detected validation problems

· Added Sort Glyphs feature

· Enhanced the paste special feature

· Minor tweaks

4.0 [May 16, 2003]
· Windows XP Theme support 

· Improved Open Installed Fonts window 

· Added High-Logic Online in Help menu 

· Sample glyph to be used on empty glyphs 

· Zoom to selected 

· Improved Import Image feature 

· Several new toolbar buttons 

· Snap to grid (points and contours and glyphs) 

· Snap to user defined guidelines (points and contours and glyphs) 

· Split TrueType Collection or Extract TrueType Fonts from TrueType Collection 

· Glyph Validation features 

· Added import kerning pairs support to the AutoKern feature 

· A Font Creator Program Explorer context menu item
3.1.3 [December 9, 2002]
· Improved the AutoNaming wizard 

· Improved Unicode support in the Preview window 

· Improved Unicode support in the Naming fields
3.1.2 [November 29, 2002]
· Added Insert Glyph toolbar button
· Added more shortcuts

· New naming wizard
3.1.1 [November 3, 2002]
· Fixed paste special mapping bug

· Fixed some minor bugs
· Improved the help file
3.1 [October 3, 2002]
· Added a complete the help file

· Added background image support
· Some minor improvements

· Fixed a couple of minor bugs
3.0.2 [November 3, 2000]
· Added combine and split contours functionality

· Fixed two minor bugs
3.0.1 [October 7, 2000]
· "Make simple" that converts composite glyphs to simple glyphs.

· New "Find" option that enables you to find glyphs through their
postscript name or mapping values.

· "Preview Window" where you can see a sample text while editing your
glyphs.

· Improved the undo redo functionality.

· Copy and paste selections of glyphs.

· Character to Glyph Index Mappings now show the Unicode Character Names.

· Add mappings through the Unicode Block Selection Feature.

· The kerning window shows the two glyphs in the same area.

· PCL5 window.

· AutoMetrics.

· AutoKern.

· Updated the tutorial.

· A lot of other minor improvements and new features.

3.0 Beta 1 [July 30, 2000] 
· A complete rebuild of the software.

2.2 [January 30, 2000] 
· Updated the tutorial (to version 2.2).

· Fixed Windows NT access problem with registry and installed fonts.

· Extended the naming fields also added load and save functionality.

· Added Monospaced support; adjust distance between letters (requested by Richard R. Kramer and Eric K. Braun).

· Added more keyboard shortcuts; read the tutorial regarding simple glyphs for specific information.

· Small adjustments to the templates; version field was not correct.

· Added an optionally fixed zoom level when opening a glyph. (Antony Shipley mentioned this one).

· Various tiny bug fixes and enhancements.

2.1 [November 14, 1999]
· Updated the tutorial (to version 2.1).

· Improved the default new font templates. The symbol template used wrong mappings.

· Added drag and drop functionality to open font files dragged from the explorer to FCP.

· Added Naming fields License Agreement and License Agreement Link. 

· The Position and the Size Tab on the Transformation Tool Bar now have the actual location and size of the selected contours. 

· Added "Select All" functionality for both contours and points. 

· If a composite glyph used two or more times a same glyph (like the double-quote ") only one was removed when trying to delete the used glyph. 

· A composite glyph should be set to an empty glyph after all its used glyphs are removed. 

· Added "delete gaspranges" available through right-click from menu-item "grayscale..". 

· Fixed a bug that occurred when closing FCP while two or more fonts were still opened. 

2.0 [August 30, 1999]
· The created and modified date and time properties were not handled correctly.

· Bug fixed (introduced in version 1.2.1) that resulted in only square (or empty) characters in the test window.

· Bug fixed that prohibited deleting glyphs in fonts without kerning.

· The Font Creator Program now prevents exceptions when encountering wrong registry keys when opening the installed fonts window.

· Added 'Use my metrics' to composite glyph window.

· Bug fixed that caused an exception when removing the kerning table.

· Improved the "New Fonts..." feature.

· Code mappings from the General->Cmap menu item now works with both decimal and hexadecimal values (Thanks to Michael von Glasow).

· Now you can select what header (postscript name or map codes) is shown above the glyphs in the overview window (Suggested by Tom Thornton, Eric Dowty, Anders Sande and a lot of other people)

· Set the maximum length of the Font Family Name to 31. Otherwise Windows does not recognize the font.

· Fixed a small but annoying samplebar bug.

· Added more info in statusbar while editing simple glyphs.

· Fixed a bug that didn't enable the paste button when another Font Creator Program performed a copy operation.

1.2.3 [August 1, 1999]
· Added functionality that changes the bearings in the glyph edit windows.

· Some minor bug fixes. 

· Panose information swapped the wrong way. (This bug and the two below were noticed by Uwe Schröder)

· Width classification bug fixed.

· Handling of backup files didn't work properly.

1.2.2 [June 12, 1999]
· First release of the tutorial!

· Added Grayscale support. Found in General->Grayscale... 

· Pasting bitmap from clipboard is now allowed (in glyph edit window). 

· Bug fixed, now hinting will be removed when editing a glyph. This was not always the case in version 1.2.1. 

· Added a SpinEdit to the Threshold in the Image to Contour window. 

· Fixed a bug with the glyphs advanced width and left side bearings. 

· Added ascent and decent lines in glyph edit window. 

1.2.1 [June 2, 1999]
· Kerning glyphs

· Preserve unknown tables.

· Preserve hinting in font and/ or glyphs. Hinting will only be removed when editing a glyph.

· Reserved Postscript names are mapped to the .notdef name.

· FCP now 'highlights' unused glyphs (actually a little box is shown in the glyph overview window).

1.2 [May 26, 1999]
· New advanced feature Image to Glyph conversion added - available from Contours->Import Image... Finally you can add your signature, logo and complete handwriting into your own fonts!

· Added High-Logic [HL] to the Vendor List!

· After saving a font file the font is assumed to be unmodified. This improves the functionality added in version 1.1.4.

1.1.4 [May 15, 1999]
· Improved the Splash screen.

· Overlapping points are now drawn as one point. This prevents an even number of points on the exact same position to hide themselves out.

· Improved the Change setting for Unicode <-> Symbol.

· Now FCP does a better job of remembering what fonts have been modified. In other words, fonts that not have been changed are now closed without the annoying warning of "saving the font Y/N?". (Thanks to Gwidon S. Naskrent). One more thing; because FCP isn't able to see wheather there's changed anything in a 'General' menu item, FCP assumes the font has been changed if one of those menu items has been selected.

· Fixed a bug that occurred when closing all windows at ones. It will still occur when you have opened more than 100 fonts at ones.

· About the Transformation Toolbar - changed the minimum value of the Size edit boxes from -32767 to 1 and changed the direction from the y-axis. 

1.1.3 [April 22, 1999]
· Fixed a strange bug that occurred when using a mousewheel after FCP was shell executed because an associated file got opened.

· Finished the toolwindow mentioned in release 1.1.2. Jeff Williams encouraged me to make this feature so manual changes could be made.

· Added 'snap to grid' support. (Gave it a higher priority thanks to Jeff Lee)

· Changed the way the actual grid point size behaves. Now it really helps when trying to line up those long lines.

· The functionality of the 'New contour' feature has been changed. Now the user has to design the contour (manually draw the points). This makes it a lot easier to quickly add contours.

· Also a lot of small changes and some internal restructuring has taken place.

· The 'testing a font' feature inside the Font Creator Program now supports printing.

1.1.2 [April 9, 1999]
· Double-click in the Glyph Edit window now changes from contour mode to point mode and back.

· Multiple Undo and Redo Boxes like MS products.

· Associating the .ttf extension to FCP was never a problem but now it is able to restore the association to the previous application.

· Finally fixed a bug that sometimes occurred while pasting a large number of glyphs, contours or points.

· New Floating and dockable toolbars so now FCP has an even more professional interface.

· Added a checkbox that specifies whether the Font Creator Program should redraw the editing screen while moving contours and points.

· Started with a toolwindow where you can edit contours and points by typing coordinates etc. This is not finished yet...

1.1.1c [March 15, 1999]
· Better way of testing the fonts inside FCP, now all character sets are available.

1.1.1b [March 14, 1999]
· Some small fixes, but the improvements are quite big!

· Updated the new font templates.

· Added some features in the Metrics menu item. Previous versions prevented installing and creating Symbol fonts.

[March 11, 1999]
· Completely redesigned the font installation procedure. Now you are guided through a Wizard, making it possible to inform you when a font is already installed.

· Open installed font file located in a folder other than the default windows folder now works as expected.

· Backups for fonts located in the default windows font folder are saved to the fcp folder. This way Windows won't get confused about which fonts actually are installed.

· Fixed byte versus smallint bug. Some composite glyphs had an unexpected change of the x-offset -- Henry Kammler thanks for reporting this bug.

· Added color to the glyph captions. This option (like a lot of other options) can be changed through the "Edit->Options" menu item.

· Made the char grid navigable via arrow keys. The scrollbar lost focus. Gwidon S. Naskrent mentioned this bug and a lot of good tips.

· When a font has corrupted glyphs they won't show up, you'll see a red rectangle instead.

[March 3, 1999]
· Some major bug fixes and a lot of new features added.

· Finally all required internal font properties are available.

· New bearings button added.

· New Table Info menu item added.

· Some useful tips through the 'tip of the day' feature.

· A lot of index properties changed to descriptions.

· New functionality -- convert between Unicode to Symbol Platform.

1.0.8 [February 21, 1999]
· Added new menu item "Mode" where you can change between contourmode and pointmode while editing a simple glyph.

· Extended the glyph properties window.

· New settings window added to the General menu item.

· Some major/ fundamental bug fixes, according to deleting contours and points.

· Changed the way of inserting and deleting glyphs. Now all edit-glyphs windows of the current font have to close before you can perform those operations.

· More options added to the "Edit -> Option" menu item.

· Added some new internal calculations, improves the quality of the font file.

· The "File -> New..." menu item has been implemented. You can choose between a new symbol font and a normal (Unicode) font.

· Added some settings like glyph width, height and size at overview and samples window.

1.0.7 [February 16, 1999] 

· Some major bug fixes. 

· Found some nasty bugs in the Undo, Redo and Repeat functionality. 

1.0.6 [February 7, 1999]
· Some minor changes (button and window positions, sizes etc...)

· Registry items like recently opened files, position and size of mainform and tool window(s).

· Registration window, for registered users. At the moment it doesn't mean they get more features. But future versions will have some restrictions for unregistered users.

· New edit window for changing a glyph's internal name.

· Fixed a bug with the zoomin button.

· Fixed a bug with selecting multiple contours.

1.0.5 [January 25, 1999]
· Fixed problem with locating the help file. Fixed thanks to Tom TCNS, Derek Baker and Del Fullmer.

· Open Font files now allows you to open fonts in the Windows font directory.

1.0.4 [November 4, 1998]
· Fixed a couple of submenu (right-click menu's) items that where not attached to the existing functionality.

· Corrected our e-mail and web-site address in the help file.

· A little more documentation in the help file. Working on this one, but it will take some time.

· Direct connection through the program to a file at our site, of course only if the user (you) want this!

1.0 [April 11, 1998]

· First public release.

[November 1, 1997]

· Preview release

Development started September 14, 1997

Research started March 10, 1997

